Some users are experiencing errors while creating new Jira and Confluence sites

Incident Report for Compass

Resolved

On March 14th, 2025, between 09:00 and 19:14 UTC, some customers experienced issues creating new sites.

The errors occurring for some users during new site creation should now be resolved.
Posted 24 days ago. Mar 14, 2025 - 20:46 UTC

Investigating

We are investigating cases of errors for some users creating new sites. We will provide more details within the next hour.
Posted 24 days ago. Mar 14, 2025 - 18:54 UTC
This incident affected: Signup.