The Developer Experience and Pull Requests dashboard (in the Teams page) include incorrect PR data

Incident Report for Compass

Resolved

The incident has been resolved.
Posted 10 months ago. Jun 17, 2024 - 12:29 UTC

Monitoring

We've resolved the issue and are monitoring to verify changes.
Posted 10 months ago. Jun 17, 2024 - 08:48 UTC

Identified

The Developer Experience and Pull Requests dashboard in the Teams page include incorrect PR data from other repositories (in the same workspace) connected to the Compass instance. The root cause has been identified and a fix is in progress.
Posted 10 months ago. Jun 17, 2024 - 05:39 UTC
This incident affected: Integrations (Bitbucket).